Public Repository

Last pushed: 2 years ago
Short Description
Clone of Neo4J 2.2.0 with update-flag and insecure-auth
Full Description
  1. Neo4J 2.2.0 introduced a requirement to authenticate on the first initialization of the DB.
    This doesn't work well with Docker when every time you start your database is the "first" time.
    So this image contains a custom configuration file where the authentication requirement is disabled.
  2. GrapheneDB works with Neo4J 2.1.3, which is incompatible with Neo4J 2.2.0. By default, the newer version won't upgrade the database you use unless you set the "upgrade" flag in the configuration file. For this reason this image also has that flag enabled in its configuration file.
Docker Pull Command
Owner
augury