Public | Automated Build

Last pushed: a year ago
Short Description
BentoJS API on Node 6
Full Description


Bento API

Installation

Server Requirements

The BentoJS framwork has a few system requirements. These requirements are fufilled by our docker distribution files, so its highly recommended that you use Docker to manage your server requirements.

However, if you are not using Docker, you need to make sure your server meets the following requirements:

  • node.js >= 6.2.1
  • Redis >= 3.0.0

Database requires either a mysql or postgres instance running.

Installing BentoJS

Installing BentoJS is currently handled by cloning the desired boilerplate branch.

# Clone github repo
$ git clone https://github.com/bentojs/api.git projectName

Before continuing with your installation its important to note that the bentojs-api-sql package is required for the default interface model. Make sure you do not remove this package when running vanilla bentojs.

Move into the api folder and perform the following operations:

# Install npm dependencies
$ npm install -g nodemon
$ npm install

License

The MIT License (MIT) found in LICENSE.md

Docker Pull Command
Owner
bentojs
Source Repository