Public Repository

Last pushed: 3 days ago
Short Description
Organizr container from linuxserver.io
Full Description

The LinuxServer.io team brings you another container release featuring easy user mapping and community support. Find us for support at:

  • forum.linuxserver.io
  • IRC on freenode at #linuxserver.io
  • Podcast covers everything to do with getting the most from your Linux Server plus a focus on all things Docker and containerisation!

lsiocommunity/organizr

HTPC/Homelab Services Organizer - Written in PHP

Usage

docker create \
  --name=organizr \
  -v <path to data>:/config \
  -e PGID=<gid> -e PUID=<uid>  \
  -p 80:80 \
  lsiocommunity/organizr

Parameters

The parameters are split into two halves, separated by a colon, the left hand side representing the host and the right the container side. For example with a port -p external:internal - what this shows is the port mapping from internal to external of the container. So -p 8080:80 would expose port 80 from inside the container to be accessible from the host's IP on port 8080 http://192.168.x.x:8080 would show you what's running INSIDE the container on port 80.

  • -p 80 - the port(s)
  • -v /config - config files for organizr
  • -e PGID for GroupID - see below for explanation
  • -e PUID for UserID - see below for explanation

It is based on alpine linux with s6 overlay, for shell access whilst the container is running do docker exec -it organizr /bin/bash.

User / Group Identifiers

Sometimes when using data volumes (-v flags) permissions issues can arise between the host OS and the container. We avoid this issue by allowing you to specify the user PUID and group PGID. Ensure the data volume directory on the host is owned by the same user you specify and it will "just work" ™.

In this instance PUID=1001 and PGID=1001. To find yours use id user as below:

  $ id <dockeruser>
    uid=1001(dockeruser) gid=1001(dockergroup) groups=1001(dockergroup)

Setting up the application

Setup accounts etc via the webui, more info at Organizr.

Info

  • Shell access whilst the container is running: docker exec -it organizr /bin/bash
  • To monitor the logs of the container in realtime: docker logs -f organizr

  • container version number

docker inspect -f '{{ index .Config.Labels "build_version" }}' organizr

  • image version number

docker inspect -f '{{ index .Config.Labels "build_version" }}' lsiocommunity/organizr

Versions

  • 25.05.17: Rebase to alpine linux 3.6.
  • 02.05.17: Add php7-curl package.
  • 12.04.17: Add php7-ldap package.
  • 10.03.17: Initial Release.
Docker Pull Command
Owner
lsiocommunity

Comments (9)
simonk83
4 months ago

I keep seeing this crop up in the logs, is this something that needs to be adjusted in the image?

WARNING: [pool www] server reached pm.max_children setting (5), consider raising it

codepoet
5 months ago

It looks like the Dashboard directory is a git repo of the source of the app. This breaks my config as I have all the /config volumes in app-specific directories under a local git repo so I can check in config changes and keep them under version control. Since the git repo here is ignoring the config files and has a remote set to the distribution, I have no way to back these files up other than manually copying or hard-linking them elsewhere (the latter will break when they're re-written).

I'd love to see this re-thought so that /config here actually just points to the config directory rather than the whole app.

aptalca
5 months ago

@moosetracks you can run this behind linuxserver.io's letsencrypt/nginx reverse proxy container: https://hub.docker.com/r/linuxserver/letsencrypt/

It has fail2ban built-in as well

moosetracks
5 months ago

Thanks, working well. Is there any chance the community would make a copy of this container to include letsencrypt and fail2ban or vice versa?

thirso
5 months ago

Thank you!

sparklyballs
5 months ago

version 30 had the PDO error because the image was pulling dependencies based on php 7.1 but our baseimage at that time was on php 7.0.
the baseimage has now been updated and the latest tag of this image now works.

lazuruz
5 months ago

It appears that things broken when the last commit was made (added php7-curl).

To fix this you can roll back to the previous version.

Simply stop the Docker container - "docker stop organizr"

delete the container and image - "docker container rm organizr" (assuming container is named organizr. "docker image rm container id here"

Then redownload older image - I went like 5 days back . "docker pull lsiocommunity/organizr:29"

thirso
5 months ago

I'm a big fat noob but I managed to get the previous version that's working like this:

docker pull lsiocommunity/organizr:29

and then I used docker run with lsiocommunity/organizr:29 instead of lsiocommunity/organizr

encryptedmedia
5 months ago

Also having the same error as thirso. Just wiped my OS and starting from scratch, went to reinstall this and received the same error.

Fatal error: Uncaught Error: Class 'PDO' not found in /config/www/Dashboard/user.php:160 Stack trace: #0 /config/www/Dashboard/index.php(67): User->__construct('registration_ca...') #1 {main} thrown in /config/www/Dashboard/user.php on line 160