Public | Automated Build

Last pushed: 2 years ago
Short Description
Short description is empty for this repo.
Full Description

ELK GELF

Docker image of ELK stack (Elasticsearch + Logstash + Kibana) with GELF input support.
This repo was forked of fayndee/elk-logback!

Get started

  1. Pull the docker image: docker pull philippbauer/elk-gelf
  2. Run the docker container:
    docker run -d -v /root/elasticsearch/:/var/lib/elasticsearch/elasticsearch -p 9200:9200 -p 12201:12201/udp -p 5601:5601 philippbauer/elk-gelf

Embedded configuration

Service ports are configured as below and are exposed by default.

port protocol service description
9200 TCP Elasticsearch Elasticsearch service port.
12201 TCP Logstash Logstash GELF input port.
5601 TCP Kibana Kibana UI port.
Docker Pull Command
Owner
philippbauer
Source Repository

Comments (2)
szabogyula
2 years ago

kibana could not be started, please check elasticsearch configuration.

for me too.

freiit
2 years ago

When I start the example, i get an endless loop:

sysctl: setting key "vm.max_map_count": Read-only file system
logstash is already running
kibana: wait for elasticsearch to start up, 1 seconds elapsed...
kibana: wait for elasticsearch to start up, 2 seconds elapsed...
kibana: wait for elasticsearch to start up, 3 seconds elapsed...
kibana: wait for elasticsearch to start up, 4 seconds elapsed...
kibana: wait for elasticsearch to start up, 5 seconds elapsed...
kibana: wait for elasticsearch to start up, 6 seconds elapsed...
kibana: wait for elasticsearch to start up, 7 seconds elapsed...
kibana: wait for elasticsearch to start up, 8 seconds elapsed...
kibana: wait for elasticsearch to start up, 9 seconds elapsed...
kibana: wait for elasticsearch to start up, 10 seconds elapsed...
kibana could not be started, please check elasticsearch configuration.

  • Starting Elasticsearch Server
    sysctl: setting key "vm.max_map_count": Read-only file system
    logstash is already running
    kibana: wait for elasticsearch to start up, 1 seconds elapsed...
    kibana: wait for elasticsearch to start up, 2 seconds elapsed...
    kibana: wait for elasticsearch to start up, 3 seconds elapsed...

Can I fix this somehow?