Public Repository

Last pushed: 7 months ago
Short Description
Short description is empty for this repo.
Full Description

DEPRECATED

This image is officially deprecated in favor of the standard ruby image, and will receive no further updates after 2016-12-31 (Dec 31, 2016). Please adjust your usage accordingly.

For most usages of this image, it was already not bringing in rails from this image, but actually from your project's Gemfile, so the only "value" being added here was the pre-installing of nodejs, mysql-client, postgresql-client, and sqlite3 for various uses of the rails framework.

For example, a Dockerfile similar to the following would be a good starting point for a Rails project using PostgreSQL:

FROM ruby:2.3

RUN apt-get update \
    && apt-get install -y --no-install-recommends \
        postgresql-client \
    && rm -rf /var/lib/apt/lists/*

WORKDIR /usr/src/app
COPY Gemfile* ./
RUN bundle install
COPY . .

EXPOSE 3000
CMD ["rails", "server", "-b", "0.0.0.0"]

About this Repo

This is the Git repo of the Docker official image for rails. See the Docker Hub page for the full readme on how to use this Docker image and for information regarding contributing and issues.

The full readme is generated over in docker-library/docs, specifically in docker-library/docs/rails.

See a change merged here that doesn't show up on the Docker Hub yet? Check the "library/rails" manifest file in the docker-library/official-images repo, especially PRs with the "library/rails" label on that repo. For more information about the official images process, see the docker-library/official-images readme.


<!-- THIS FILE IS GENERATED BY https://github.com/docker-library/docs/blob/master/generate-repo-stub-readme.sh -->

Docker Pull Command
Owner
tonyfg