Public Repository

Last pushed: 2 months ago
Short Description
Ubuntu 14.04 + CUDA 8.0 + cuDNN v5 + Tensorflow 1.3.0 + Keras 1.2.2
Full Description

Requirements

Followings should be installed on host machine.

  • Nvidia driver version 378.13 or 381.22
  • CUDA 8.0

Tags

Theano backends

Tag Ubuntu Display driver CUDA cuDNN Theano Keras
cu378.13_th0.8.2 14.04 v378.13 8.0 v5 0.8.2 1.2.2
cu378.13_th0.9.0 14.04 v378.13 8.0 v5 0.9.0 1.2.2
cu381.22_th0.8.2 14.04 v381.22 8.0 v5 0.8.2 1.2.2
cu381.22_th0.9.0 14.04 v381.22 8.0 v5 0.9.0 1.2.2

Tensorflow backends

Tag Ubuntu Display driver CUDA cuDNN Tensorflow Keras
cu378.13_tf1.0.1 14.04 v378.13 8.0 v5 1.0.1 1.2.2
cu378.13_tf1.1.0 14.04 v378.13 8.0 v5 1.1.0 1.2.2
cu378.13_tf1.2.1 14.04 v378.13 8.0 v5 1.2.1 1.2.2
cu378.13_tf1.3.0 14.04 v378.13 8.0 v5 1.3.0 1.2.2
cu381.22_tf1.0.1 14.04 v381.22 8.0 v5 1.0.1 1.2.2
cu381.22_tf1.1.0 14.04 v381.22 8.0 v5 1.1.0 1.2.2
cu381.22_tf1.2.1 14.04 v381.22 8.0 v5 1.2.1 1.2.2
cu381.22_tf1.3.0 14.04 v381.22 8.0 v5 1.3.0 1.2.2
latest 14.04 v381.22 8.0 v5 1.3.0 1.2.2

Usages

docker run -it -p 22 -p 6006 -p 8888 --device /dev/nvidiactl --device /dev/nvidia-uvm --device /dev/nvidia0 yunjsjaesung/keras

Notes

For Nvidia GTX 1080Ti, Nvidia display driver 378.13 or higher is required.
For Nvidia Titan Xp, Nvidia display driver 381.22 or higher is required.

Docker Pull Command
Owner
yunjsjaesung

Comments (0)