This image is based on cassandra 2.2.8.
I add cassandra.yaml to enable set user with password.
ERROR 06:11:55 Exception encountered during startup: Unknown listen_address '::1 127.0.0.1'
This is caused by bellow script in [docker-entrypoint.sh](https://github.com/docker-library/cassandra/blob/master/2.2/docker-entrypoint.sh):if [ "$CASSANDRA_LISTEN_ADDRESS" = 'auto' ]; then
CASSANDRA_LISTEN_ADDRESS="$(hostname --ip-address)"
fi
So I suggest to set env CASSANDRA_LISTEN_ADDRESS when start container or change your server's hostname and mapping ip address.
reference:org.apache.cassandra.auth.CassandraRoleManager doesn’t support PASSWORD
Content type
Image
Digest
Size
163.5 MB
Last updated
over 9 years ago
docker pull adolphlwq/container-cassandra