CryoFall Game Server image.
100K+

You need to have a 64-bit x86-compatible OS (no ARM support) with at least 1.5 GB of available RAM and 1 GB of free disk space. The full hardware requirements are listed here.
If you don't have docker installed, please install Docker Engine by following this guide https://docs.docker.com/install/
To pull the latest R33 (v1.33.x.x) server image please use this command:
docker pull atomictorch/cryofall-server:1.33
If you get a permission error, perhaps Docker Hub has limited access from your IP address so you need to log in with your Docker account.
Let's start in on the external port 6000 with cryofall-server-1 docker volume (for persistent data), and attach the console to it:
docker run --name cryofall-server-1 --log-opt max-size=10m --log-opt max-file=1 -it --rm -p 6000:6000/udp -v cryofall-server-1:/app/Data atomictorch/cryofall-server:1.33 loadOrNew
It will launch the container and attach the console.
Please note: you can add -d argument to start the server detached but then you will be unable to see any startup errors if there are any.
When attached, press Ctrl+P then Ctrl+Q.
In some cases it might not work—then you can simply close the terminal and reconnect with a new SSH connection.
Please use this command to attach to the running container:
docker attach cryofall-server-1
When you're attached to the container, you can request it to stop after 60 seconds by entering this command:
stop 60 Bye-bye server your shutdown message here
Please note that you can configure the timer duration and the shutdown message. Already connected players will have some time to prepare for the server shutdown. When the shutdown timer is active new players cannot connect to the server (the connection will be refused and the shutdown message will be displayed).
If you want to change the external port from 6000 to anything else, please change the first number before : in the docker run command listed above. E.g. to use port 12345 replace -p 6000:6000 with -p 12345:6000
(Do not change the port number in the ServerSettings.xml config file, always keep it 6000 (default)—because you're running the server in a Docker container, the change will have no intended effect)
You can locate the data folder by using the Linux "find" tool:
find / -name "cryofall-server-1"
Usually it's here: /var/lib/docker/volumes/cryofall-server-1
Navigate to the data folder (see the previous section):
cd /var/lib/docker/volumes/cryofall-server-1/_data
then check the files there:
ls
Use a text editor of your choice. For example, nano:
nano SettingsServer.xml
nano ServerRates.config
Please follow the server setup guide to configure your server http://wiki.atomictorch.com/CryoFall/Server/Setup
Stop the game server as explained above in the Stop the container section and then repeat the first step Download CryoFall game server image. Then start the container again. If you're updating to a new major version please follow the Server Update section in this guide.
Content type
Image
Digest
sha256:669dc1520…
Size
493.1 MB
Last updated
about 4 years ago
docker pull atomictorch/cryofall-server:1.33