If any error occurs when using docker exec, try this:
yum downgrade docker docker-client docker-common
vim:
apt-get update
apt-get install vim
ssl: edit /etc/apache2/ports.conf /etc/apache2/site-enabled/default-ssl.conf with a sample:
<VirtualHost 192.168.0.1:443>
DocumentRoot /var/www/html2
ServerName www.example.com
SSLEngine on
SSLCertificateFile /path/to/your_domain_name.crt
SSLCertificateKeyFile /path/to/your_private.key
</VirtualHost>
you may need to use:
a2enmod ssl
service apache2 restart
dont forget to copy your .pem and .key(for free ssl and installation of nginx or else,go and see https://support.cloudflare.com/hc/en-us/sections/207182687-Origin-CA)
and start the wordpress by:
docker run --name some-wordpress --link mysql:mysql -d -p 80:80 -p 443:443 comm/wordpress:vim-ssl
Content type
Image
Digest
Size
174.5 MB
Last updated
over 7 years ago
docker pull comm/wordpress:190307