how to use it docker run -v /data:/var/hdfs/namenode -d --name hdfs-nn -P dataman/hdfs-namenode
264
hdfs namenode in docker
docker run -v /data:/var/hdfs/namenode -d --name hdfs-nn -p 8020:8020 -p 50070:50070 dataman/hdfs-namenode:2.7.1
Q1: Cmd bin/hdfs namenode format is triggering error: Caused by: java.net.UnknownHostException: YOUR_HOSTNAME?
A1. Add line 127.0.0.1 YOUR_HOSTNAME to file /etc/hosts will shoot it maybe.
Content type
Image
Digest
Size
451.7 MB
Last updated
almost 10 years ago
docker pull dataman/hdfs-namenode:2.7.1