Sign inSign up

dockerjak/redis

By dockerjak

•Updated about 10 years ago

redis 3.2.3

Artifact
0

118

dockerjak/redis repository overview

安装redis,建立redis容器: docker pull dockerjak/redis:3.2.3 创建本地redis配置文件和持久化数据目录分别为:/mnt/myredis/conf/redis.conf /mnt/myredis/data

启动一个容器: docker run --name=redis -v /mnt/myredis/data:/data -v /mnt/myredis/conf/redis.conf:/usr/local/etc/redis/redis.conf -d -p 6379:6379 dockerjak/redis:3.2.3 redis-server --appendonly yes

如果想进入容器内,使用如下命令: 启动redis-cli客户端,找到redis-cli 启动即可 在myredis容器中启动一个诸如打开shell的交互式任务,这条命令会在myredis容器中创建一个新的bash会话 docker exec -t -i redis /bin/bash cd /usr/local/bin

可能遇到的错误信息: docker logs redis 可以看到错误信息:chown: cannot read directory '.' : Permission denied

原因: 原因是CentOS7中的安全模块selinux把权限禁掉了

至少有以下三种方式解决挂载的目录没有权限的问题:

  • 在运行容器的时候,给容器加特权:

示例:docker run --name=myredis --privileged=true -v /mnt/myredis/data:/data

  • 临时关闭selinux:

示例:su -c "setenforce 0" 注意:之后要记得重新开启selinux,命令:su -c "setenforce 1"

  • 添加selinux规则,将要挂载的目录添加到白名单:

示例:chcon -Rt svirt_sandbox_file_t /mnt/myredis

Tag summary

Content type

Unrecognized

Digest

Size

70.8 MB

Last updated

about 10 years ago

docker pull dockerjak/redis:3.2.3