UJCMS 是一款基于 Java 的开源企业级网站内容管理系统(Java CMS)
7.1K
docker run --name ujcms -p 8080:8080 -e UJCMS_DB_HOST=mysql -e UJCMS_DB_PORT=3306 -e UJCMS_DB_NAME=ujcms -e UJCMS_DB_USER=ujcms -e UJCMS_DB_PASSWORD=my-secret-pw -d dromara/ujcms:latest
docker-compose.yamlservices:
ujcms:
image: dromara/ujcms:latest
restart: always
ports:
- "8080:8080"
environment:
UJCMS_DB_HOST: mysql
UJCMS_DB_PORT: 3306
UJCMS_DB_NAME: ujcms
UJCMS_DB_USER: ujcms
UJCMS_DB_PASSWORD: my-secret-pw
depends_on:
mysql:
condition: service_healthy
restart: true
volumes:
- ujcms:/ujcms/static
mysql:
image: mysql:8.0
restart: always
healthcheck: # Health check definition
test: ["CMD", "mysqladmin", "ping", "-h", "localhost", "-u", "root", "-p$$MYSQL_ROOT_PASSWORD"]
interval: 10s
timeout: 10s
retries: 5
start_period: 30s
environment:
MYSQL_DATABASE: ujcms
MYSQL_USER: ujcms
MYSQL_PASSWORD: my-secret-pw
MYSQL_ROOT_PASSWORD: my-root-pw
volumes:
- mysql:/var/lib/mysql
volumes:
ujcms:
mysql:
首次运行程序,系统会自动创建数据库表和初始化数据库,需要一些时间(3-6分钟),请耐心等待。直到出现类似 com.ujcms.cms.Application: Started Application in xxx seconds 信息,代表程序启动完成。
程序启动时出现 LockException: Could not acquire change log lock 或 Waiting for changelog lock... 错误信息。解决办法:将数据库 databasechangeloglock 表中数据清空(请注意,不是 databasechangelog 表),或者删除数据库所有表(也可重建数据库),再次启动程序即可。原因:程序启动时会自动创建、升级数据库表结构,如果此时强行关闭程序,再次启动可能会出现这个问题。
前台地址:http://localhost:8080/,使用手机访问前台或者使用浏览器模拟手机访问前台,会自适应显示手机端的界面。
后台地址:http://localhost:8080/cp/,用户名:admin,密码:password。
UJCMS_DB_HOST数据库主机。可以是域名、IP或主机名,如 www.example.com 192.168.0.1 mysql
UJCMS_DB_PORT数据库端口。MySQL默认端口为 3306
UJCMS_DB_NAME数据库名。
UJCMS_DB_USER数据库用户名。
UJCMS_DB_PASSWORD数据库密码。
Content type
Image
Digest
sha256:b6be61963…
Size
300 MB
Last updated
8 days ago
docker pull dromara/ujcms