Description: This property controls the maximum number of milliseconds that a client will wait for a connection from the pool
Default value: 30000
DB_IDLE_TIMEOUT
Description: This property controls the maximum amount of time that a connection is allowed to sit idle in the pool. This setting only applies when DB_MINIMUM_IDLE is defined to be less than DB_MAXPOOLSIZE
Default value: 600000
DB_INITIALIZATION_FAIL_TIMEOUT
Description: This property controls whether the pool will "fail fast" if the pool cannot be seeded with an initial connection successfully
Default value: 30000
DB_KEEPALIVE_TIME
Description: This property controls how frequently HikariCP will attempt to keep a connection alive, in order to prevent it from being timed out by the database or network infrastructure (0 - disabled)
Default value: 0
DB_LEAK_DETECTION_THRESHOLD
Description: This property controls the amount of time that a connection can be out of the pool before a message is logged indicating a possible connection leak (0 - disabled)
Default value: 30000
DB_MAXPOOLSIZE
Description: This property controls the maximum size that the pool is allowed to reach, including both idle and in-use connections
Default value: 10
DB_MAX_LIFETIME
Description: This property controls the maximum lifetime of a connection in the pool
Default value: 1800000
DB_MINIMUM_IDLE
Description: This property controls the minimum number of idle connections that HikariCP tries to maintain in the pool
Default value: 10
DB_VALIDATION_TIMEOUT
Description: This property controls the maximum amount of time that a connection will be tested for aliveness. This value must be less than the DB_CONNECTION_TIMEOUT
Default value: 5000
KAFKA_HOST
Description: Kafka broker hostname
Default value: kafka
KAFKA_PORT
Description: Kafka broker port
Default value: 9092
KAFKA_SECURITY_PROTOCOL
Description: Kafka security protocol used to communicate with brokers (SSL or PLAINTEXT)
Default value: PLAINTEXT
KAFKA_SSL_KEYSTORE_LOCATION
Description: The location of the Kafka key store file. This is optional for client and can be used for two-way authentication for client.
KAFKA_SSL_KEYSTORE_PASSWORD
Description: The store password for the Kafka key store file. This is optional for client and only needed if 'ssl.keystore.location' is configured.
KAFKA_SSL_TRUSTSTORE_LOCATION
Description: The location of the Kafka trust store file.
KAFKA_SSL_TRUSTSTORE_PASSWORD
Description: The password for the Kafka trust store file. If a password is not set, trust store file configured will still be used, but integrity checking is disabled.