Description: This property controls the maximum number of milliseconds that a client will wait for a connection from the pool
Default value: 30000
DB_IDLE_TIMEOUT
Description: This property controls the maximum amount of time that a connection is allowed to sit idle in the pool. This setting only applies when DB_MINIMUM_IDLE is defined to be less than DB_MAXPOOLSIZE
Default value: 600000
DB_INITIALIZATION_FAIL_TIMEOUT
Description: This property controls whether the pool will "fail fast" if the pool cannot be seeded with an initial connection successfully
Default value: 30000
DB_KEEPALIVE_TIME
Description: This property controls how frequently HikariCP will attempt to keep a connection alive, in order to prevent it from being timed out by the database or network infrastructure (0 - disabled)
Default value: 0
DB_LEAK_DETECTION_THRESHOLD
Description: This property controls the amount of time that a connection can be out of the pool before a message is logged indicating a possible connection leak (0 - disabled)
Default value: 30000
DB_MAXPOOLSIZE
Description: This property controls the maximum size that the pool is allowed to reach, including both idle and in-use connections
Default value: 10
DB_MAX_LIFETIME
Description: This property controls the maximum lifetime of a connection in the pool
Default value: 1800000
DB_MINIMUM_IDLE
Description: This property controls the minimum number of idle connections that HikariCP tries to maintain in the pool
Default value: 10
DB_VALIDATION_TIMEOUT
Description: This property controls the maximum amount of time that a connection will be tested for aliveness. This value must be less than the DB_CONNECTION_TIMEOUT
Default value: 5000
AUTHORITY_ARCHIVES_EXPIRATION_PERIOD
Description: The retention period in days for keeping the deleted authorities in authority_archive DB table
Default value: 7
DI_CANCELED_JOB_CACHE_MAX_SIZE
Description: Maximum number of cancelled data-import job IDs stored per module instance.
Default value: 500
DI_CANCELED_JOB_CACHE_TTL
Description: Expiration time for cancelled data-import job IDs in the local cache (e.g. 24h, 30m).
Default value: 24h
ENV
Description: The logical name of the deployment, must be unique across all environments using the same shared Kafka/Elasticsearch clusters, a-z (any case), 0-9, -, _ symbols only allowed
Default value: folio
INSTANCE_STORAGE_QUERY_BATCH_SIZE
Description: Number of instances to retrieve from inventory storage per one request (Max 90 - based on maximum URI length)
Default value: 50
KAFKA_AUTHORITIES_CONSUMER_CONCURRENCY
Description: Number of kafka concurrent threads for inventory.authority message consuming.
Default value: 1
KAFKA_AUTHORITY_SOURCE_FILE_TOPIC_PARTITIONS
Description: Amount of partitions for authority-authority-source-file topic.
Description: Replication factor for links.instance-authority-stats topic.
KAFKA_INSTANCE_AUTHORITY_TOPIC_PARTITIONS
Description: Amount of partitions for links.instance-authority topic.
Default value: 10
KAFKA_INSTANCE_AUTHORITY_TOPIC_REPLICATION_FACTOR
Description: Replication factor for links.instance-authority topic.
KAFKA_PORT
Description: Kafka broker port
Default value: 9092
KAFKA_SECURITY_PROTOCOL
Description: Kafka security protocol used to communicate with brokers (SSL or PLAINTEXT)
Default value: PLAINTEXT
KAFKA_SSL_KEYSTORE_LOCATION
Description: The location of the Kafka key store file. This is optional for client and can be used for two-way authentication for client.
KAFKA_SSL_KEYSTORE_PASSWORD
Description: The store password for the Kafka key store file. This is optional for client and only needed if 'ssl.keystore.location' is configured.
KAFKA_SSL_TRUSTSTORE_LOCATION
Description: The location of the Kafka trust store file.
KAFKA_SSL_TRUSTSTORE_PASSWORD
Description: The password for the Kafka trust store file. If a password is not set, trust store file configured will still be used, but integrity checking is disabled.
OKAPI_URL
Description: Okapi URL
Default value: okapi
S3_ACCESS_KEY_ID
Description: S3 compatible service access key
S3_BUCKET
Description: S3 compatible service bucket
S3_IS_AWS
Description: Specify if AWS S3 is used as files storage
Default value: true
S3_LOCAL_SUB_PATH
Description: S3 subpath for local files storage
Default value: mod-entities-links
S3_REGION
Description: S3 compatible service region
Default value: us-west-2
S3_RETRY_COUNT
Description: Specify number of retries if S3 client return any kind of error
Default value: 3
S3_RETRY_DELAY_MS
Description: Specify millisecond delay between retries if S3 client return any kind of error