This is the nut-webui docker image, which implements the web-based UI for Network UPS Tools (NUT)
50K+
This is the nut-webui docker image, which implements the web-based UI for the upsd daemon from https://networkupstools.org/.
pull as usual:
docker pull gpdm/nut-webui[:<tag>]
tags:
then run it as follows:
docker run -d \
-p 80:80 \
-v /path/to/nut-config:/etc/nut \
[-p 443:443 -v /path/to/ssl-certs:/etc/ssl -e SSL_PRIVATE_KEY=ssl-cert-snakeoil.key -e SSL_CERTIFICATE=ssl-cert-snakeoil.pem] \
gpdm/nut-webui[:<tag>]
This docker runs nginx, and thus exposes the following ports:
For the upsstats CGI tools, you need these configuration files:
These files cannot be provided through environment variables, you have to use a config volume as shown:
/data/dockers/nut-webui/config-v /data/dockers/nut-webui/config:/etc/nutThe container will fail to start when no volume is mounted, or not all needed files are present!
Some sample config files are provided for your conventience in the master repository. You may use them as a starting point, however I recommed to have a indepth look at the official Network UPS Tools documentation.
For the nginx web server, TLS/SSL can be optionally enabled as well:
/data/dockets/nut-webui/certs-v /data/dockers/nut-webui/certs:/etc/sslssl-cert-snakeoil.key rather than an absolute path, i.e. /etc/ssl/ssl-cert-snakeoil.key
The permissions on the private must be set to 0600, 0400 or 0640.ssl-cert-snakeoil.crt rather than an absolute path, i.e. /etc/ssl/ssl-cert-snakeoil.crtThe container will treat an absent ssl config volume as non-critical error, and resume with internal self-signed certificates.
When you provide a config volume, and both the vars for the private key and the certificate are set, any failure during startup validation (wrong file mode, wrong path, wrong modulus, etc) will be treated as critical error.


Content type
Image
Digest
sha256:fa0ed2e4b…
Size
97.2 MB
Last updated
10 months ago
docker pull gpdm/nut-webui