软件版本:
宝塔7.1.1
Nginx -Tengine2.2.4(2.3.0)
MySQL 5.5.62
PHP-7.2
按步骤在ssh输入以下命令即可在N1上搭建好
docker pull hibuddies/bt-lnmp:latest
ip link set eth0 promisc on
docker network create -d macvlan --subnet=192.168.1.0/24 --gateway=192.168.1.1 -o parent=eth0 macnet
其中的192.168.1.0/24是我主路由的网段,192.168.1.1是我主路由的IP地址,也就是网关地址,这两个根据自己的实际情况修改
docker run -it --name web --restart always --network macnet hibuddies/bt-lnmp /start.sh
其中的web是容器名字,可以自行修改。用这条命令创建容器后,容器开机自启,并且启动后会自动启动面板和环境。
1.mysql在创建后的第一次启动可能会启动失败,在创建容器后手动输入
/etc/init.d/mysqld start
即可启动
2.容器的IP可以用 docker inspect 容器ID | grep IPAddress 查看;容器ID通过 docker container ls 可以看到
3.docker容器的网络分配似乎是从192.168.X.2开始的,如果访问不到容器,可能是IP冲突,在路由器设置一下即可
宝塔面板登录页面是
你的IP:8888/startwish
账号startwish
密码startwish
系统root账户的密码是startwish
Content type
Image
Digest
Size
1 GB
Last updated
over 5 years ago
docker pull hibuddies/bt-lnmp