haproxy with letsencrypt hooks
4.7K
This image is Krumware's extension of https://github.com/cnadeau/letsencrypt-dockercloud-haproxy
haproxy image will create default self signed certificates so HAproxy can start before having any real certificates.
It will also watch /etc/letsencrypt/live directory and reload HAproxy when required.
haproxy:
image: 'krumware/docker-haproxy-letsencrypt:latest
links:
- <letsencrypt-container>
- <your-project-container>
ports:
- '3003:443'
volumes:
- '/var/run/docker.sock:/var/run/docker.sock'
volumes_from:
- <letsencrypt-container>
Dont forget to link letsencrypt container. By Default Port 443 is https and 80 is http. It has access to the volumes exposed by letsencrypt which contains all SSL certificates generated information. It proves quite useful when letsencrypt service is somehow unable to start.
Content type
Image
Digest
Size
15.4 MB
Last updated
over 9 years ago
docker pull krumware/docker-haproxy-letsencrypt