Since 31 Mar 2017, CentOS 5 is not supported any more.
If you run a container using centos:5 image, yum will not work.
tlsv1 is not accpted by vault repository, if you use vault repository, yum upadte will fail with error: M2Crypto.SSL.SSLError: tlsv1 alert protocol version.
baseurl of repos to http://archive.kernel.org/centos-vault/5.11/. (base, extras, updates)Use in command-line.
docker run --rm -it lazywalker/centos5 /bin/bash
Or, replacement for centos:5 in Dockerfile
FROM lazywalker:centos5
Content type
Image
Digest
Size
96.4 MB
Last updated
over 4 years ago
docker pull lazywalker/centos5