Postfix mail relay. Copy of github.com/alterrebe/docker-mail-relay configuration with client TLS.
1.7K
Contains:
Processes are managed by supervisord, including cronjobs
The container provides a simple proxy relay for environments like Amazon VPC where you may have private servers with no Internet connection and therefore with no access to external mail relays (e.g. Amazon SES, SendGrid and others). You need to supply the container with your external mail relay address and credentials. The configuration is tested with Amazon SES.
25RELAY_HOST_NAME=relay.example.com: A DNS name for this relay container (usually the same as the Docker's hostname)ACCEPTED_NETWORKS=192.168.0.0/16 172.16.0.0/12 10.0.0.0/8: A network (or a list of networks) to accept mail fromEXT_RELAY_HOST=email-smtp.us-east-1.amazonaws.com: External relay DNS nameEXT_RELAY_PORT=25: External relay TCP portSMTP_LOGIN=: Login to connect to the external relay (required, otherwise the container fails to start)SMTP_PASSWORD=: Password to connect to the external relay (required, otherwise the container fails to start)USE_TLS=: Remote require tls. Might be "yes" or "no". Default: no.TLS_VERIFY=: Trust level for checking the remote side cert. (none, may, encrypt, dane, dane-only, fingerprint, verify, secure). Default: may.SMTPD_USE_TLS=: announce STARTTLS support to remote SMTP clients, but do not require that clients use TLS encryption. Might be "yes" or "no". Default: no.SMTPD_LOG_LVL=: Enable additional Postfix SMTP server logging of TLS activity. Might be "1,2,3,4". Do not use "2" or higher except in case of problems. Default: 0.Launch Postfix container:
$ docker run -d -h relay.example.com --name="mailrelay" -e SMTP_LOGIN=myLogin -e SMTP_PASSWORD=myPassword -p 25:25 alterrebe/postfix-relay
Content type
Image
Digest
sha256:e1c0be18a…
Size
98.2 MB
Last updated
almost 11 years ago
docker pull lits/docker-mail-relay