Public Repository

Last pushed: 12 days ago
Short Description
Ruby is a dynamic, reflective, object-oriented, general-purpose, open-source programming language.
Full Description

Supported tags and respective Dockerfile links

(ppc64le/ruby build job)

Quick reference

What is Ruby?

Ruby is a dynamic, reflective, object-oriented, general-purpose, open-source programming language. According to its authors, Ruby was influenced by Perl, Smalltalk, Eiffel, Ada, and Lisp. It supports multiple programming paradigms, including functional, object-oriented, and imperative. It also has a dynamic type system and automatic memory management.

wikipedia.org/wiki/Ruby_(programming_language)

How to use this image

Create a Dockerfile in your Ruby app project

FROM ppc64le/ruby:2.1-onbuild
CMD ["./your-daemon-or-script.rb"]

Put this file in the root of your app, next to the Gemfile.

This image includes multiple ONBUILD triggers which should be all you need to bootstrap most applications. The build will COPY . /usr/src/app and RUN bundle install.

You can then build and run the Ruby image:

$ docker build -t my-ruby-app .
$ docker run -it --name my-running-script my-ruby-app

Generate a Gemfile.lock

The onbuild tag expects a Gemfile.lock in your app directory. This docker run will help you generate one. Run it in the root of your app, next to the Gemfile:

$ docker run --rm -v "$PWD":/usr/src/app -w /usr/src/app ppc64le/ruby:2.1 bundle install

Run a single Ruby script

For many simple, single file projects, you may find it inconvenient to write a complete Dockerfile. In such cases, you can run a Ruby script by using the Ruby Docker image directly:

$ docker run -it --rm --name my-running-script -v "$PWD":/usr/src/myapp -w /usr/src/myapp ppc64le/ruby:2.1 ruby your-daemon-or-script.rb

Encoding

By default, Ruby inherits the locale of the environment in which it is run. For most users running Ruby on their desktop systems, that means it's likely using some variation of *.UTF-8 (en_US.UTF-8, etc). In Docker however, the default locale is C, which can have unexpected results. If your application needs to interact with UTF-8, it is recommended that you explicitly adjust the locale of your image/container via -e LANG=C.UTF-8 or ENV LANG C.UTF-8.

Image Variants

The ppc64le/ruby images come in many flavors, each designed for a specific use case.

ppc64le/ruby:<version>

This is the defacto image. If you are unsure about what your needs are, you probably want to use this one. It is designed to be used both as a throw away container (mount your source code and start the container to start your app), as well as the base to build other images off of. This tag is based off of buildpack-deps. buildpack-deps is designed for the average user of docker who has many images on their system. It, by design, has a large number of extremely common Debian packages. This reduces the number of packages that images that derive from it need to install, thus reducing the overall size of all images on your system.

ppc64le/ruby:slim

This image does not contain the common packages contained in the default tag and only contains the minimal packages needed to run ppc64le/ruby. Unless you are working in an environment where only the ppc64le/ruby image will be deployed and you have space constraints, we highly recommend using the default image of this repository.

ppc64le/ruby:onbuild

The ONBUILD image variants are deprecated, and their usage is discouraged. For more details, see docker-library/official-images#2076.

While the onbuild variant is really useful for "getting off the ground running" (zero to Dockerized in a short period of time), it's not recommended for long-term usage within a project due to the lack of control over when the ONBUILD triggers fire (see also docker/docker#5714, docker/docker#8240, docker/docker#11917).

Once you've got a handle on how your project functions within Docker, you'll probably want to adjust your Dockerfile to inherit from a non-onbuild variant and copy the commands from the onbuild variant Dockerfile (moving the ONBUILD lines to the end and removing the ONBUILD keywords) into your own file so that you have tighter control over them and more transparency for yourself and others looking at your Dockerfile as to what it does. This also makes it easier to add additional requirements as time goes on (such as installing more packages before performing the previously-ONBUILD steps).

License

View license information for the software contained in this image.

Docker Pull Command
Owner
ppc64le

Comments (1)
oscarzhao
a year ago

Compile and Build fluent image for ppc64le, needs ruby to be "Invalid gemspec in [/var/lib/gems/1.9.1/specifications/string-scrub-0.1.1.gemspec]: Illformed requirement ["< 2.1, >= 1.9.3"]", how can i avoid it, please help