Base image for the Rapid7 InsightVM Content Service.
10K+
This document describes the InsightVM Content Service.
By default the service does not load all resources into memory. Instead, the service will load and cache resources as they are requested. Response times can fluctuate as requested resources are loaded and cached, and response times will be different if a requested resource is cached versus when a requested resource is loaded and cached.
| Requests per Second | Unique Vulnerabilities | Cores | Memory |
|---|---|---|---|
| 1 - 6,000 | 0 - 20,000 | 1 | 500MB |
| 1 - 6,000 | 20,001 - 50,000 | 1 | 750MB |
| 1 - 6,000 | 50,001 - 100,000 | 1 | 1GB |
| 1 - 6,000 | 100,001 + | 1 | 1.5GB |
| 1 - 12,000 | 0 - 20,000 | 2 | 500MB |
| 1 - 12,000 | 50,000 - 50,000 | 2 | 750MB |
| 1 - 12,000 | 100,000 - 100,000 | 2 | 1GB |
| 1 - 12,000 | 100,001 + | 2 | 1.5GB |
| 1 - 24,000 | 0 - 20,000 | 4 | 500MB |
| 1 - 24,000 | 50,000 - 50,000 | 4 | 750MB |
| 1 - 24,000 | 100,000 - 100,000 | 4 | 1GB |
| 1 - 24,000 | 100,001 + | 4 | 1.5GB |
| CPU | Measured Performance at Full Load |
|---|---|
| AMD EPYC 7571 | 6,000 requests per second per core |
| Intel(R) Xeon(R) Platinum 8124M @ 3.00GHz | 8,000 requests per second per core |
| Resources Cached | Measured Memory Usage |
|---|---|
| 10% | 324MB |
| 25% | 494MB |
| 50% | 779MB |
| 75% | 1064MB |
| 100% | 1348MB |
Memory utilization will grow over time as new content is added. The size of requested resources will influence memory utilization.
| Image Size |
|---|
| 300MB - 400MB |
Disk utilization will grow over time as new content is added.
The service will read from disk when a resource is not cached. The amount and size of reads from disk will decrease as resources are cached until no more reads from disk are required.
Minimum The amount of traffic if the smallest resource was requested in all requests.Average The amount of traffic if an average size resource was requested in all requests.Minimum The amount of traffic if the largest resource was requested in all requests.BPS Bytes Per SecondKBPS Kilobytes Per SecondKBPS Megabytes Per Second| Requests per Second | Minimum | Average | Maximum |
|---|---|---|---|
| 1 | 148 BPS | 875 BPS | 534 KBPS |
| Requests per Second | Minimum | Average | Maximum |
|---|---|---|---|
| 1 | 360 BPS | 1 KBPS | 210 KBPS |
The InsightVM Content Service container listens on TCP port 8081 at runtime for HTTP client communication. The port is not published by default. To publish the port when running the container, use the -p flag on docker run to publish and map one or more ports, or the -P flag to publish all exposed ports and map them to high-order ports.
This section describes the InsightVM Content Service Application Programming Interface (API) Version 1. Unless noted otherwise this API accepts and produces the application/xml media type.
Versioning is specified in the URL and the base path of this API is: http://<host>:<port>/api/<version>/
An instance resource is a "leaf" level resource that may be retrieved, optionally nested within a collection resource. Instance resources are usually retrievable with opaque identifiers.
The resource path for instance resources follows the convention: /api/1/{resource_name}/{instance_id}
The following HTTP operations are supported throughout this API. The general usage of the operation and both its failure and success status codes are outlined below.
| Verb | Usage | Success | Failure |
|---|---|---|---|
GET | Used to retrieve a resource by identifier, or a collection of resources by type. | 200 | 404, 403, 500 |
GETRetrieves the details of a specific resource by its identifier. The details retrieved can be controlled through property selection and property views. The content of the resource is returned within the body of the response in the acceptable media type.
The following response statuses may be returned by this API.
| Status | Meaning | Usage |
|---|---|---|
| 200 | OK | The operation performed without error according to the specification of the request, and no more specific 2xx code is suitable. |
| 403 | Forbidden | The resource exists to which the user has access, but the operating requested is not permitted. |
| 404 | Not Found | The resource specified could not be located, does not exist, or an unauthenticated client does not have permissions to a resource. |
| 500 | Internal Server Error | An internal and unexpected error has occurred on the server at no fault of the client. |
GET /api/1/solutions/{id}Returns the details for a solution that can remediate one or more vulnerabilities.
| Path Parameter | Description |
|---|---|
| id | The identifier of the solution. |
| Status | Meaning | Usage |
|---|---|---|
| 200 | OK | The operation performed without error according to the specification of the request, and no more specific 2xx code is suitable. |
| 403 | Forbidden | The resource exists to which the user has access, but the operating requested is not permitted. |
| 404 | Not Found | The resource specified could not be located, does not exist, or an unauthenticated client does not have permissions to a resource. |
| 500 | Internal Server Error | An internal and unexpected error has occurred on the server at no fault of the client. |
GET /api/1/vulnerabilities/{id}Returns the details for a vulnerability.
| Path Parameter | Description |
|---|---|
| id | The identifier of the vulnerability. |
| Status | Meaning | Usage |
|---|---|---|
| 200 | OK | The operation performed without error according to the specification of the request, and no more specific 2xx code is suitable. |
| 403 | Forbidden | The resource exists to which the user has access, but the operating requested is not permitted. |
| 404 | Not Found | The resource specified could not be located, does not exist, or an unauthenticated client does not have permissions to a resource. |
| 500 | Internal Server Error | An internal and unexpected error has occurred on the server at no fault of the client. |
Content type
Image
Digest
sha256:32b0ef8bd…
Size
494.5 MB
Last updated
7 days ago
docker pull rapid7/insightvm_content_service