Simple SMTP relay with authentication against remote peers
316
This is a minimal SMTP smarthost relay that is able to authenticate itself against uplinks and make sure that senders are originating from approved domain only.
The following environment variables are available:
EXIM_ALLOWED_NETS: a list of allowed CIDR subnets separated by column. By default :127.0.0.1EXIM_SMTP_RELAY: a list of SMTP relays separated by column. Separate ports by ::EXIM_SMTP_USERNAME, EXIM_SMTP_PASSWORD: client SMTP credentials. No authentication will be performed of either is not setEXIM_ALLOWED_DOMAIN: allowed senders domain. If not set, no checks are performed.EXIM_FALLBACK_SENDER: a sender address that all senders from non-allowed domains will be rewritten to. If not set, no rewrite happens, all non-allowed domains will be rejectedContent type
Image
Digest
Size
52.1 MB
Last updated
over 9 years ago
docker pull stanvit/trouvus-mailer