Mysql server with suitable defaults: innodb file-per-table, utf8mb4, osx support.
2.4K
This image is based on the official mysql image, so all settings from that image apply.
Add custom configuration options as files under conf.d. These will be mounted in the server under /etc/mysql/conf,d.
If you are running on OSX and are storing the server's data on the host, the MYSQL server will fail because the user running the server on the container does not match the local user that owns the data directories on the host. To fix this, set OSX environment variable to true when running the container based on this image.
docker run -d -e OSX=true unitedasian/mysql
This is not required if the data is stored in the container itself and not on the host.
Content type
Image
Digest
Size
117.9 MB
Last updated
over 10 years ago
docker pull unitedasian/mysql