Sign inSign up

wohaokun/elasticsearch

By wohaokun

•Updated over 2 years ago

elasticsearch by wanghaokun

Image
0

92

wohaokun/elasticsearch repository overview

⁠notes

v8.11.4 来源于官方 elasticsearch:8.11.4 ,在此基础上进行配置优化及包含如下功能:

  • ik分词插件

⁠command

docker run -d -p 9200:9200 -p 9300:9300 --name elasticsearch wohaokun/elasticsearch:8.11.4
docker exec -it elasticsearch bash

⁠Question

若是启动失败,可通过 docker logs elasticsearch 查看具体失败原因

Q: max virtual memory areas vm.max_map_count [65530] is too low

{"@timestamp":"2024-01-20T06:36:09.492Z", "log.level":"ERROR", "message":"node validation exception\n[1] bootstrap checks failed. You must address the points described in the following [1] lines before starting Elasticsearch. For more information see [https://www.elastic.co/guide/en/elasticsearch/reference/8.11/bootstrap-checks.html]\nbootstrap check failure [1] of [1]: max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]; for more information see [https://www.elastic.co/guide/en/elasticsearch/reference/8.11/_maximum_map_count_check.html]", "ecs.version": "1.2.0","service.name":"ES_ECS","event.dataset":"elasticsearch.server","process.thread.name":"main","log.logger":"org.elasticsearch.bootstrap.Elasticsearch","elasticsearch.node.name":"a78dabed5a5c","elasticsearch.cluster.name":"docker-cluster"}

A: 修改主机系统内核参数 vi /etc/sysctl.conf ,增加下面配置vm.max_map_count=262144后,运行命令 sysctl -p 重新应用配置即可。

Tag summary

Content type

Image

Digest

sha256:1eccda390…

Size

693.2 MB

Last updated

over 2 years ago

docker pull wohaokun/elasticsearch:8.11.4