基于 Steve0x2a/DLimiter,仅适用于plex+plex2alist 的直链播放。
461
面对场景:当使用plex2alist直链播放时,某些路径下的媒体文件播放应当忽略限速。
修改conf/config.toml文件,对plex的配置项增加ignore_key=xxx,如下:
[plex]
enable = true
url="https://36-26-97-76.b34faa6321184d1f83536e37d9a818ef.plex.direct:32400"
token="xxx"
ignore_key="" # 当填入03cd2时,文件路径上包含03cd2的媒体文件的播放并不限速,留空则不启用该忽略条件。
我是将115网盘通过clouddrive2挂载到
/share/xxx/03cd2/上的,因此选定路径关键字03cd2,凡包含03cd2的路径下的媒体文件播放不限速。
docker compose方式部署:
version: '3'
services:
dlimiter:
image: zfhxi/dlimiter4plex:dev
restart: always
volumes:
- ./conf:/app/conf
ports:
- 8088:8088
environment:
- DLIMITER_CN_UPDATE=true
- DLIMITER_AUTO_UPDATE=true
- DLIMITER_PORT=8088
- TZ=Asia/Shanghai
# - DLIMITER_REPO_URL="https://mirror.ghproxy.com/https://github.com/zfhxi/DLimiter4plex.git" # 当你访问github网络很差时,可以考虑解除本行注释
hostname: dlimiter
container_name: dlimiter
第一次启动会失败,需要把conf/config_example.toml重命名为conf/config.toml,并修改配置文件后重启容器。
plex的webhooks设置:
127.0.0.1:8088)/player/plex然后使用docker logs -f dlimiter查看日志,当播放网盘直链的媒体文件时,日志中会有类似如下输出:
hypercorn.error - INFO - 106 Running on http://0.0.0.0:8088 (CTRL + C to quit)
DLimiter - INFO - 33 监测到Plex播放的《化物语 -> 黑仪重蟹 其之一》所在路径包含03cd2,忽略限速!
DLimiter - INFO - 33 监测到Plex播放的《化物语 -> 黑仪重蟹 其之一》所在路径包含03cd2,忽略限速!
DLimiter - INFO - 33 监测到Plex播放的《化物语 -> 黑仪重蟹 其之一》所在路径包含03cd2,忽略限速!
DLimiter - INFO - 33 监测到Plex播放的《化物语 -> 黑仪重蟹 其之一》所在路径包含03cd2,忽略限速!
Content type
Image
Digest
sha256:cd7be07a1…
Size
33.6 MB
Last updated
over 2 years ago
docker pull zfhxi/dlimiter4plex:dev